Aleromod.com Aleromod.com

Go Back   Aleromod.com > Performance Related > L61 2.2L Ecotec Specific

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-28-2016, 08:47 AM   #1
tpro442
GX Member
 
Join Date: Dec 2015
Location: Ashland WI
Posts: 12
tpro442 is on a distinguished road
Cam Position sensor

I have a code for Camshaft position sensor on my 03 2.2 Ecotec. I have been looking on the internet and searched here. Do they have one? Or does it use the crank sensor? Also, I think I fixed my oil usage problem, replaced the $6 hose that runs from the valve cover to the air box, still on full after three weeks, was using half a quart a week. Thanks for the help.
tpro442 is offline   Reply With Quote
Old 01-28-2016, 10:02 AM   #2
1970cs
GX Member
 
1970cs's Avatar
 
Join Date: Dec 2015
Location: Grand Ledge, MI
Posts: 116
1970cs is on a distinguished road
http://www.autozone.com/repairinfo/r...96b43f8036e7b6

According the information above, yes.

Pat
1970cs is offline   Reply With Quote
Old 01-28-2016, 08:14 PM   #3
tpro442
GX Member
 
Join Date: Dec 2015
Location: Ashland WI
Posts: 12
tpro442 is on a distinguished road
Thanks, but the L61 2.2 ecotec is different from the LN2 2.2 ecotec, for some reason. There is no Camshaft sensor in that location. My trouble code is: PO340B, Camshaft position sensor circuit, so it would have to have one, right?
tpro442 is offline   Reply With Quote
Old 01-28-2016, 09:07 PM   #4
1970cs
GX Member
 
1970cs's Avatar
 
Join Date: Dec 2015
Location: Grand Ledge, MI
Posts: 116
1970cs is on a distinguished road
You are correct! I am glad AZ repair manual was accurate! 07 and up had them.

Anyways does your car run?
http://www.obd-codes.com/forums/viewtopic.php?t=8609
1970cs is offline   Reply With Quote
Old 01-29-2016, 09:23 AM   #5
tpro442
GX Member
 
Join Date: Dec 2015
Location: Ashland WI
Posts: 12
tpro442 is on a distinguished road
Yes, It does run. Engine has 230,000 miles on it. It runs well cold, kind of stumbles under load when warm. Plugs are new and contacts for ignition are clean with dielctric grease on them. Going to do a compression test. It used a half quart of oil in three weeks, no long distance driving.
tpro442 is offline   Reply With Quote
Old 01-29-2016, 10:05 AM   #6
1970cs
GX Member
 
1970cs's Avatar
 
Join Date: Dec 2015
Location: Grand Ledge, MI
Posts: 116
1970cs is on a distinguished road
Sounds like you went through the link I provided? I wish the best for you, but reading through that link again and very similar except yours runs.

Pat
1970cs is offline   Reply With Quote
Old 01-31-2016, 07:48 PM   #7
tpro442
GX Member
 
Join Date: Dec 2015
Location: Ashland WI
Posts: 12
tpro442 is on a distinguished road
So, did a compression test today, here are the results from the right: 170, 165, 155, 183. I put oil in number 2 and 3, they both came up to 215. Valves are probably good, engine is just wore.
tpro442 is offline   Reply With Quote
Old 01-31-2016, 08:39 PM   #8
1970cs
GX Member
 
1970cs's Avatar
 
Join Date: Dec 2015
Location: Grand Ledge, MI
Posts: 116
1970cs is on a distinguished road
Someone will have to confirm, but does not sound to bad.

Pat
1970cs is offline   Reply With Quote
Old 02-01-2016, 09:34 AM   #9
03Alerosil
GL Member
 
03Alerosil's Avatar
 
Join Date: Dec 2013
Location: Minnesota
Posts: 590
03Alerosil is on a distinguished road
Compression is fine so I doubt it's the rings. I would say it's the valve guides in the head or it's leaking it. Half quart of oil ain't nothing. Even new cars can use oil. My 3.4 with 162,000 on it uses a quart in like 1,500 miles. I'm not worried. I had a Topaz that used a quart a week. Drove it for 3 years and never worried.
__________________
Stock 2003 3.4 alero. Pioneer 3400ub. Pioneer 4 way 6x9s. Pioneer 3 way 4x6s. 800 watt JVC amp powering 2 12" MTX Audio terminators.
03Alerosil is offline   Reply With Quote
Old 02-02-2016, 09:26 AM   #10
tpro442
GX Member
 
Join Date: Dec 2015
Location: Ashland WI
Posts: 12
tpro442 is on a distinguished road
Thanks, Just going to drive it.
tpro442 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin Version 3.6.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.