Aleromod.com Aleromod.com

Go Back   Aleromod.com > Performance Related > L61 2.2L Ecotec Specific

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-18-2016, 07:38 PM   #1
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
I Want My Cruse Control Back!!!

my cruse control used to work on and off, now its 100% dead.
when it was working on and off, sometimes it would shut off on its own when it was working. i can get the steering wheel to light up, but i press the set button and nothing happens.
long story short, easily over 50% of my driving is thruway. can someone please be my hero and TELL ME HOW TO FIX IT. i have basic mechanic experience but electrical is where i go HUH???
please and thank you
ps, im the guy who had a brake failure and crashed the front end of my car
__________________
Gotta love the 2 door coup.

Last edited by kbubb91 : 11-18-2016 at 11:27 PM.
kbubb91 is offline   Reply With Quote
Old 11-18-2016, 11:25 PM   #2
a.graham52
Trenton Fire 8
 
a.graham52's Avatar
 
Join Date: Dec 2009
Location: The Island of Misfit Toys, Maine
Posts: 1,967
a.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond reputea.graham52 has a reputation beyond repute
Send a message via AIM to a.graham52 Send a message via MSN to a.graham52
First of all need more detail.

Is cruising turning on and lighting up? Or just not "setting"?

If it's not lighting up, can you hold the button in to make it work? I had two alerts like this... jammed a pennie between button and wheel to keep on. Drove for several years like that.

Otherwise check fuses.

If it's not setting, then it's probably brake switch.
__________________
2002 GMC Sierra 4.3 (W), 5spd, 4x4.
Mods: K&N drop-in, modded air box, modded throttle blade, X injectors, Flowmaster 50 series, BBK underdrive Pulleys (3pc), e-fans, personal HPT tune.

a.graham52 is offline   Reply With Quote
Old 11-18-2016, 11:29 PM   #3
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
the on button on the left side of the steering wheel turns on(yellow light). the light on the dashboard that says cruse dose not turn on then i press the lower right button "set"

im guessing fuses but which fuses, the engine fuses or the fuses on the side of the steering wheel
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 11-19-2016, 01:05 AM   #4
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
im going to go to walmart tomorrow, buy the fuse kit and replace all of the small colored fuses in my car(both fuse boxes), make sure they are all fresh. then ill have to see about getting the special fuses.
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 11-19-2016, 04:27 AM   #5
Babyblue
GL Member
 
Babyblue's Avatar
 
Join Date: Nov 2012
Location: Grand Rapids, Michigan
Posts: 406
Babyblue is on a distinguished road
Mine did this...what I had to do was take fitting off the cruise control Mondale. then reconnect the end that comes out of the module to the that wire that connects to the throttle body. hope this helps. you might get a better idea what im talking about if you just take it apart.
__________________
2004 GLS #40 of the final 500. 3500 swap and F-40 6-speed.
Babyblue is offline   Reply With Quote
Old 11-19-2016, 10:17 AM   #6
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
so our cars DO have a cruse control mondule, i tried buying a replacement and they dont sell them on ebay or anywhere.
so i have to do repair work on the existing unit, alright.
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 11-20-2016, 02:07 AM   #7
Babyblue
GL Member
 
Babyblue's Avatar
 
Join Date: Nov 2012
Location: Grand Rapids, Michigan
Posts: 406
Babyblue is on a distinguished road
Quote:
Originally Posted by kbubb91 View Post
so our cars DO have a cruse control mondule, i tried buying a replacement and they dont sell them on ebay or anywhere.
so i have to do repair work on the existing unit, alright.

Yeah, do what I said it could be your problem
__________________
2004 GLS #40 of the final 500. 3500 swap and F-40 6-speed.
Babyblue is offline   Reply With Quote
Old 11-20-2016, 08:31 PM   #8
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
yeah just waiting for the snow to leave NY, i dont have a garage.
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 12-11-2016, 03:06 PM   #9
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
i figured out the cruise control issue, ITS A FUSE, 2 FUSES to be exact.

passengers side fuse box, there are two 2A fuses that needed to be replaced, that explains why sometimes it would work and some times it would fail, corroded fuse.
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 12-14-2016, 01:23 AM   #10
Babyblue
GL Member
 
Babyblue's Avatar
 
Join Date: Nov 2012
Location: Grand Rapids, Michigan
Posts: 406
Babyblue is on a distinguished road
Quote:
Originally Posted by kbubb91 View Post
i figured out the cruise control issue, ITS A FUSE, 2 FUSES to be exact.

passengers side fuse box, there are two 2A fuses that needed to be replaced, that explains why sometimes it would work and some times it would fail, corroded fuse.

Nice job!
__________________
2004 GLS #40 of the final 500. 3500 swap and F-40 6-speed.
Babyblue is offline   Reply With Quote
Old 12-20-2016, 05:39 PM   #11
zzyzzx
GLS member
 
zzyzzx's Avatar
 
Join Date: Mar 2008
Location: Baltimore, MD USA
Posts: 5,418
zzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond repute
You know if fuses go, it's usually a symptom, not the root cause.
zzyzzx is offline   Reply With Quote
Old 12-20-2016, 10:39 PM   #12
kbubb91
GX Member
 
Join Date: Aug 2014
Location: schenectady county
Posts: 68
kbubb91 is on a distinguished road
yes, you win a prize, cruse control failed as fast as it came back, the fuse is shorting out. im about to say eff this car, im ready for a new one, im happy i was able to bring it back from the dead after a crash but im like eff this shit. also my turn signals are failing now. guessing my wires are effed
__________________
Gotta love the 2 door coup.
kbubb91 is offline   Reply With Quote
Old 12-21-2016, 12:11 AM   #13
zzyzzx
GLS member
 
zzyzzx's Avatar
 
Join Date: Mar 2008
Location: Baltimore, MD USA
Posts: 5,418
zzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond reputezzyzzx has a reputation beyond repute
Quote:
Originally Posted by kbubb91 View Post
guessing my wires are effed

You have a short in the wiring someplace. Probably not that hard to find if the car has been wrecked. At least you know probably where to look.
zzyzzx is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:26 AM.


Powered by vBulletin Version 3.6.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.