Aleromod.com Aleromod.com

Go Back   Aleromod.com > General Help > Common Questions & Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-10-2016, 12:58 PM   #1
aroundincircles
GX Member
 
Join Date: Apr 2016
Location: Chandler, AZ
Posts: 64
aroundincircles is on a distinguished road
turn signals are going to drive me crazy! help?

So ever since I bought my alero, the turn signals have been funky, They will flash quickly when I'm idling, but slow down after I accelerate (high RPMs). but more annoyingly is sometimes they won't turn on at all. I flick the stock and... Nothing. The emergency blinkers will still work as expected, and none of my bulbs are burned out.

Does anybody have any suggestion on where to start first? is there a relay separate from the emergency flashers for the blinkers? anybody else have this similar issue?
aroundincircles is offline   Reply With Quote
Old 08-10-2016, 01:06 PM   #2
sleepyalero
GLS member
 
sleepyalero's Avatar
 
Join Date: Aug 2010
Location: indy
Posts: 8,391
sleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond reputesleepyalero has a reputation beyond repute
Replace hazard switch?
__________________
[SIGPIC]
[SIGPIC]
S. . .L. . . E . . .E. . .P. . .Y. . .IS A TRAITOR--HE GOT BORED SO HE SOLD ME AFTER HAVING AN AFFAIR WITH A RICE ROCKET
Oldsnut is my Hero!
Meet Destiny, shes a 2001 Oldsmobile Alero GLS, F40 6MT swap. (#2 of 3)
2/24/14 - 200,000 miles body/motor. 22,300 on F40.
Quote:
Originally Posted by Oldsnut View Post
He would Plasti Dip his pecker if he could.
Quote:
Originally Posted by tipnitty View Post
A girl touched my Pee Pee. So you can say things are getting pretty serious for me.
sleepyalero is offline   Reply With Quote
Old 08-10-2016, 01:07 PM   #3
Redog
Aleromod part owner
 
Redog's Avatar
 
Join Date: Nov 2003
Location: Far Northeast Philadelphia, PA
Posts: 18,179
Redog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond reputeRedog has a reputation beyond repute
Send a message via AIM to Redog Send a message via Yahoo to Redog
Never heard of this, but usually anything related to the t/s needs the Hazzard warning switch replaced. Everything t/s related goes thru there.

Not too expensive of a part anymore. Check eBay, but do yourself a favor and buy the ACDelco one. Don't cheap out
__________________
33% ALEROMOD OWNER!!


2000 Olds Alero 3400 SFI 14.53 @ 94.93
1985 Olds Delta 88 307 SBO 17.96 @ 76.99
2007 Volvo V50 T5 6M 15.782 @ 89.12
www.facebook.com/kb0177
Redog is offline   Reply With Quote
Old 01-22-2017, 03:31 AM   #4
mrbreezeet1
GX Member
 
Join Date: Jan 2017
Location: Moundsville WV
Posts: 42
mrbreezeet1 is on a distinguished road
What did you come up with
mrbreezeet1 is offline   Reply With Quote
Old 01-22-2017, 09:21 AM   #5
03Alerosil
GL Member
 
03Alerosil's Avatar
 
Join Date: Dec 2013
Location: Minnesota
Posts: 590
03Alerosil is on a distinguished road
It's your multi-function switch. Mine did the same thing. The switch is shorting out internally. easy to change. Just watch out for the pin that rides on the brass horn plate.
__________________
Stock 2003 3.4 alero. Pioneer 3400ub. Pioneer 4 way 6x9s. Pioneer 3 way 4x6s. 800 watt JVC amp powering 2 12" MTX Audio terminators.
03Alerosil is offline   Reply With Quote
Old 01-22-2017, 05:30 PM   #6
mrbreezeet1
GX Member
 
Join Date: Jan 2017
Location: Moundsville WV
Posts: 42
mrbreezeet1 is on a distinguished road
Quote:
Originally Posted by 03Alerosil View Post
It's your multi-function switch. Mine did the same thing. The switch is shorting out internally. easy to change. Just watch out for the pin that rides on the brass horn plate.

Quote:
Originally Posted by mrbreezeet1 View Post
What did you come up with
I think it's nice when an OP in a case like this follows up, with what they came up with.
I see this over and over on other sites. People get there answer(s) and there gone.
When someone is searching for help, It no help when a follow up is not done.
mrbreezeet1 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:10 AM.


Powered by vBulletin Version 3.6.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.